Email Services Delayed

Incident Report for Texas Mutual Public

Resolved

All emails are now sending and delivering as expected. We will continue to monitor to ensure the service remains stable.

Thank you for your patience while we worked to restore normal functionality.
Posted Nov 21, 2025 - 11:29 CST

Update

Texas Mutual emails for account activation and forgot password may be delayed. We apologize for the inconvenience and appreciate your patience as we work to rectify the issue.
Posted Nov 21, 2025 - 11:07 CST

Investigating

All Texas Mutual emails for account activation and forgot password are not being sent. We apologize for the inconvenience and appreciate your patience as we work to rectify the issue.
Posted Nov 21, 2025 - 10:58 CST
This incident affected: Texas Mutual Online.